import nengolib

Additional extensions and tools for modelling dynamical systems in Nengo.

Installation

Nengolib is tested against Python 2.7, 3.4, 3.5, and 3.6, and Nengo 2.1.0, 2.2.0, 2.3.0, 2.4.0, 2.5.0, 2.6.0, and 2.7.0. We recommend nengo==2.7.0 for complete access to features. The Nengo GUI is not officially supported. To install:

pip install nengolib

This requires nengo>=2.1.0 numpy>=1.10, and scipy>=0.17.0. If you are having difficulty installing SciPy or NumPy, we recommend the Anaconda installer.